This project is read-only.

Unexpected Error

Jul 1, 2008 at 1:52 PM
I downloaded your cool looking calendar, and was able to install it and activate it.  However, when trying to edit a page and place the webpart, I select the calendar and as soon as I push OK, a screen appears with an unexpected error.  All I can do is close the webpart.  Anyone else have this problem?
Jul 1, 2008 at 10:16 PM


jrmitchell12 wrote:
I downloaded your cool looking calendar, and was able to install it and activate it.  However, when trying to edit a page and place the webpart, I select the calendar and as soon as I push OK, a screen appears with an unexpected error.  All I can do is close the webpart.  Anyone else have this problem?


I just downloaded it and ran the setup.  The setup appeared to have completed successfully, and I verified that it is deployed solution in the farm.....however I can't find the web part in the web part gallery. 
Jul 1, 2008 at 10:20 PM


lpcross wrote:


jrmitchell12 wrote:
I downloaded your cool looking calendar, and was able to install it and activate it.  However, when trying to edit a page and place the webpart, I select the calendar and as soon as I push OK, a screen appears with an unexpected error.  All I can do is close the webpart.  Anyone else have this problem?


I just downloaded it and ran the setup.  The setup appeared to have completed successfully, and I verified that it is deployed solution in the farm.....however I can't find the web part in the web part gallery. 

OK - I forgot to activate it as a feature.  Got that straightened out, then tried to install the web part and received "An unexpected error has occurred."  I am attempting to troubleshoot the issue.

Jul 1, 2008 at 10:31 PM


lpcross wrote:


lpcross wrote:


jrmitchell12 wrote:
I downloaded your cool looking calendar, and was able to install it and activate it.  However, when trying to edit a page and place the webpart, I select the calendar and as soon as I push OK, a screen appears with an unexpected error.  All I can do is close the webpart.  Anyone else have this problem?


I just downloaded it and ran the setup.  The setup appeared to have completed successfully, and I verified that it is deployed solution in the farm.....however I can't find the web part in the web part gallery. 

OK - I forgot to activate it as a feature.  Got that straightened out, then tried to install the web part and received "An unexpected error has occurred."  I am attempting to troubleshoot the issue.


I looked through the WebParts list in the Site Settings at the root site, clicked on ExpertCalendar.Class1.webpart and received the following error:   Request for the permission of type 'Microsoft.SharePoint.Security.SharePointPermission, Microsoft.SharePoint.Security, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c' failed.

Jul 2, 2008 at 7:32 AM



I looked through the WebParts list in the Site Settings at the root site, clicked on ExpertCalendar.Class1.webpart and received the following error:   Request for the permission of type 'Microsoft.SharePoint.Security.SharePointPermission, Microsoft.SharePoint.Security, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c' failed.



The webpart requires a higher permission to run. You obviously have your setting in the web.config set to wss_minimal. try set it to "Full". Although Microsoft don't recommend that, there is a massive workaround which quite honestly, considering the supposed problems with setting it to Full, is way to big to implement. so in all:

<trust level="Full" originUrl="" />

in web.config
Jul 2, 2008 at 10:13 PM
Thanks alot courtz!!! That worked like a charm.  I really love this calendar, so many of my departments were asking for this, and I had not had time to make one.
Jul 3, 2008 at 12:31 AM


jrmitchell12 wrote:
Thanks alot courtz!!! That worked like a charm.  I really love this calendar, so many of my departments were asking for this, and I had not had time to make one.


Thanks for the update courtz.  I'm happy to hear that you are up and running jrmitchell12.  This is new territory for me....but I'm venturing on hoping to learn.  I modified the web.config file for the site, then reset IIS.  I still get an error when trying to deploy the webpart however.   Are there additional steps that I should be taking?

Larry
Jul 3, 2008 at 5:06 AM
what error are you getting lpcross?
Jul 3, 2008 at 3:46 PM
Edited Jul 3, 2008 at 3:47 PM


courtz wrote:
what error are you getting lpcross?


Hi courtz - I'm getting the same/inital error that I received when I first tried to deploy the part.   "
An unexpected error has occurred.

Web Parts Maintenance Page: If you have permission, you can use this page to temporarily close Web Parts or remove personal settings. For more information, contact your site administrator

Do I need to remove the solution from the front end server and re-install in order for the change in the web.config security to have the proper effect?  This is what I see in Central Administration after deploying the expertcalendar.

Name: theexpertcalendar.wsp
Type: Core Solution
Contains Web Application Resource: Yes
Contains Global Assembly: No
Contains Code Access Security Policy: No
Deployment Server Type: Front-end Web server
Deployment Status: Deployed
Deployed To: (ficticious name here) http://name.group.corp/
Last Operation Result: The solution was successfully deployed.
Last Operation Details: (server and website names have been changed to protect the innocent :)  ) report server : http://name.group.corp/ : The solution was successfully deployed. 
front end server : http://name.group.corp/ : The solution was successfully deployed.
Last Operation Time: 7/2/2008 7:32 PM







Jul 7, 2008 at 11:47 AM
I'm sitting witht he same problem as lpcross - i've updated web.config and then re-rant he setup filr and then reset IIS and still getting the same original error.
Jul 8, 2008 at 4:34 AM
hey guys,

can you do me a favour and edit the web.config and set the following:

customErrors mode="Off"

CallStack="true"


Then let me know what your error is.

Jul 8, 2008 at 6:36 AM
do i need to reinstall the calendar as well - i've changed the web.config file and done an iisreset but am still getting the error
Jul 8, 2008 at 8:24 AM
try and do a remove then reinstall!

also have you done the above? if you have then post the error you get
Jul 8, 2008 at 9:50 AM
nope - still not working :-(

An unexpected error has occurred.

Web Parts Maintenance Page: If you have permission, you can use this page to temporarily close Web Parts or remove personal settings. For more information, contact your site administrator.

Troubleshoot issues with Windows SharePoint Services.

Jul 8, 2008 at 2:12 PM


TessaH wrote:
nope - still not working :-(

An unexpected error has occurred.

Web Parts Maintenance Page: If you have permission, you can use this page to temporarily close Web Parts or remove personal settings. For more information, contact your site administrator.

Troubleshoot issues with Windows SharePoint Services.



Hi - I've been out sick and haven't any done any further work on this yet.  I will try the web.config edit for flagging errors sometime today and report the results.
Jul 8, 2008 at 11:34 PM
hi tessa,

if you setup the web.config as suggested, you should get an error which is not sharepoint related. please try it again or do an iisreset and try again
Jul 9, 2008 at 6:28 AM
Hi courtz, thanks for all the help - a reboot to the box seems to have sorted it out.

Very glad I got htis sorted as it really is a great add on to MOSS :-)
Jul 30, 2008 at 8:27 PM

The following is what is added to my web.config when I install this app:

<SafeControl Assembly="TheExpertCalendar" Namespace="TheExpertCalendar" TypeName="*" Safe="True" />

All of my other apps within the safe controls section have a lot more informaiton included with them, such as Version=1.0.0.0, Culture=neutral, PublicKeyToken=blahblahblah"

Obviously, I have installed this, rebooted, and it is still not displayed. I cannot find it in any of my site features settings to activate it either. I uninstalled, reinstalled, rebooted, nothing. I made the change to Full as suggested above in the web.config as well, but my sharepoint site bombed out on me until I reverted back to my original web.config.

I would really like to get this working...please point me in the right direction.

A little more...i dug in an tried to manually import into the webpart gallery, and if I click on the view xml tab of th eweb part once added in the gallery, I get the following

<?xml version="1.0" encoding="utf-8" ?>

- <webParts>
- <webPart xmlns="http://schemas.microsoft.com/WebPart/v3">
- <metaData>
  <type name="TheExpertCalendar.Class1, TheExpertCalendar, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null" />
  <importErrorMessage>Cannot import this Web Part.</importErrorMessage>
  </metaData>
- <data>
- <properties>
  <property name="Title" type="string">Class1</property>
  <property name="Description" type="string" />
  </properties>
  </data>
  </webPart>
  </webParts>
Aug 1, 2008 at 6:17 AM
fEER

To activate this, go to C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\BIN in the command prompt.  and type stsadm -o activatefeature -name theexpertcalendar -url http://yourservername

this will show it
Aug 4, 2008 at 2:42 PM
Edited Aug 4, 2008 at 2:42 PM
Thanks a ton! This is a tremendous addition.
Oct 22, 2008 at 2:39 PM
I didn't make it to work.:( I still get the error.
I run the setup, i activated the solution and  changed the web.config to "full"

Then i restarted the machine still error ....
Any help?
Nov 5, 2008 at 8:24 PM

Hi There Courtz !

I finally was able to get back to deploy the update to web.config on our front end server.  The Expert Calendar works perfect !  Thanks a lot for sharing this.

Larry